Jump to content
BulForum.com
Sign in to follow this  
torbalan

Проблем с MDAC

Recommended Posts

Ae, нали във форума има програмисти ? Нека ударят едно рамо.

Трябва да инсталирам MDAC. За тези, които не знаят, това е Microsoft Data Access Components. Тегля от сайта на Микрософт последната версия, която излиза. Води се 2.8 SP1. При опит за инсталиране ми излиза съобщение, че сетъп-ът не поддържал инсталация върху тази ОС (в случая - моята, която е Вин ХР). Чудя се какво да правя ?

МДАК-а ми трябва за една програма за достъп на база данни през интернет и е важно да се инсталира без грешки. Пробвах да го инстална под съвместимост за Вин 2000, уж се инсталира успешно, но въпросната програмка не тръгва после...

Не мога да разбера логиката - сетъп-ът не иска да се инсталира върху по-новата ОС - Вин ХР, а при съвместимост за Вин 2000 не дава съобшения за грешка...?
 

Share this post


Link to post
Share on other sites

2019-та година сме. Последният SP за XP излезе преди 11 години! Ъпдейти не излизат от 5 години вече. Няма как да подкараш нови софтуери под XP. Вероятно въпросният софтуер използва неща които не съществуват изобщо в XP и няма как да тръгне.

Share this post


Link to post
Share on other sites

Като гледам става въпрос по-скоро за твърде стар пакет, отколкото за твърде нов. В даунлоуд секцията на това... нещо, пише следното:

Quote

Microsoft Data Access Components (MDAC) 2.8 SP1 contains core Data Access components such as the Microsoft SQL Server™ OLE DB provider and ODBC driver. This redistributable installer for the MDAC 2.8 SP1 release installs the same Data Access components as Microsoft Windows XP SP2.

Това за мен означава, че пакетът е вграден в Windows XP SP2.

Само не знам защо са намесени програмистите в тоя пост.

Share this post


Link to post
Share on other sites
6 hours ago, The AnGeL said:

 

Само не знам защо са намесени програмистите в тоя пост.

 

Защото в главите на повечето хора програмистите са хората, които единствени разбират от компютри в дълбини.

Share this post


Link to post
Share on other sites

 

 

 

 

 

 

В Details към MDAC Utility: Component Checker       пише следното:

 

Since MDAC in Windows XP SP2 or later is newer than the version (MDAC 2.8 SP1) in the last MDAC redistribution program, mdac_typ.exe no longer installs MDAC on Windows XP SP2 and later version.

Което е и отговорът на моя въпрос...Явно проблемът не е там.

Благодаря на отзовалите се!
 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...